IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Peterson Model 450 Schematic
Gerry
post Sep 18 2010, 11:22 AM
Post #1


Starting Member
*

Group: Members
Posts: 1
Joined: 18-September 10
Member No.: 4,777



I need a schmatic for a Model 450 tuner (S/N458790). I have had it for years and I use it for tuning organs. Recently it was hit by lightning (my ignorance for forgetting to unplug it). It now lights up (LED's and incandesent bulbs) and the motor turns. However, there is no LED modulation when a note is played. I pulled it apart for the first time in its life to see if anything was burnt. I did notice that one IC (L2930) was getting very hot. The voltage at the 30V test point was 28V and the other voltages marked next to the test points were very close (I believe they were approximately 15V and 5V). I checked and there is 15V getting to the Microphone board. One other question, are components still available for this model?

Any help is greatly appreciated. This tuner is still in like new shape and I am very proud to own a Peterson.
Go to the top of the page
 
+Quote Post
Sue
post Sep 20 2010, 01:19 PM
Post #2


Peterson Technician
***

Group: Root Admin
Posts: 168
Joined: 14-September 02
From: USA
Member No.: 63



QUOTE (Gerry @ Sep 18 2010, 05:22 PM) *
I need a schmatic for a Model 450 tuner (S/N458790). I have had it for years and I use it for tuning organs. Recently it was hit by lightning (my ignorance for forgetting to unplug it). It now lights up (LED's and incandesent bulbs) and the motor turns. However, there is no LED modulation when a note is played. I pulled it apart for the first time in its life to see if anything was burnt. I did notice that one IC (L2930) was getting very hot. The voltage at the 30V test point was 28V and the other voltages marked next to the test points were very close (I believe they were approximately 15V and 5V). I checked and there is 15V getting to the Microphone board. One other question, are components still available for this model?

Any help is greatly appreciated. This tuner is still in like new shape and I am very proud to own a Peterson.


Hi Gerry,

I think the problem is on the mic pre amp board.
I'll email you a schematic
Please contact me with any questions

Thanks
Sue Haslam
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 24th November 2014 - 02:54 AM